Thursday, April 05, 2007

Ada harapan baru winmodem bisa dipakai

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 0/1
Subdevice #0: subdevice #0

$ sudo /etc/init.d/sl-modem-daemon start
Starting SmartLink Modem driver for: hw:0,6.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

$ sudo wvdialconf
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

Modem Port Scan<*1>: S0 S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttySL0<*1>: ATQ0 V1 E1 -- OK
ttySL0<*1>: ATQ0 V1 E1 Z -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttySL0<*1>: Modem Identifier: ATI -- SmartLink Soft Modem
ttySL0<*1>: Speed 4800: AT -- OK
ttySL0<*1>: Speed 9600: AT -- OK
ttySL0<*1>: Speed 19200: AT -- OK
ttySL0<*1>: Speed 38400: AT -- OK
ttySL0<*1>: Speed 57600: AT -- OK
ttySL0<*1>: Speed 115200: AT -- OK
ttySL0<*1>: Speed 230400: AT -- OK
ttySL0<*1>: Speed 460800: AT -- OK
ttySL0<*1>: Max speed is 460800; that should be safe.
ttySL0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttySL0.
Modem configuration written to /etc/wvdial.conf.
ttySL0: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

2 comments:

Artur said...
This comment has been removed by the author.
Artur said...

Hi,

after I have installed sl-modem-deamon:

artur@laptop:/usr/sbin$ sudo apt-get install sl-modem-daemon
Czytanie list pakietów... Gotowe
Budowanie drzewa zależności
Reading state information... Gotowe
Zostaną zainstalowane następujące NOWE pakiety:
sl-modem-daemon
0 aktualizowanych, 1 nowo instalowanych, 0 usuwanych i 0 nieaktualizowanych.
Konieczne pobranie 510kB archiwów.
Po rozpakowaniu zostanie dodatkowo użyte 1163kB miejsca na dysku.
Pob: 1 http://pl.archive.ubuntu.com feisty/restricted sl-modem-daemon 2.9.10+2.9.9d+e-pre2-5ubuntu1 [510kB]
Pobrano 510kB w 3s (128kB/s)
Prekonfiguracja pakietów ...
Zaznaczenie poprzednio niezaznaczonego pakietu sl-modem-daemon.
(Odczytywanie bazy danych ... 116148 plików i katalogów obecnie zainstalowanych.)
Rozpakowanie sl-modem-daemon (z .../sl-modem-daemon_2.9.10+2.9.9d+e-pre2-5ubuntu1_i386.deb) ...
Konfigurowanie sl-modem-daemon (2.9.10+2.9.9d+e-pre2-5ubuntu1) ...
Pozwolenie na użycie kiepskiej jakości nazwy użytkownika.
Dodawanie użytkownika systemowego `Slmodemd' (UID 110)...
Dodawanie nowej grupy `Slmodemd' (GID 120)...
Dodawanie nowego użytkownika `Slmodemd' (UID 110) w grupie `Slmodemd'...
Nie utworzono katalogu domowego `/'.
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

So as you can see there are 2 error messages:
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.

After this:

artur@laptop:/usr/sbin$ sudo /etc/init.d/sl-modem-daemon start
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.
Starting SmartLink Modem driver for: auto.
Creating /dev/modem symlink, pointing to: /dev/ttySL0.

this same error messages:
FATAL: Module ungrab_winmodem not found.
FATAL: Module slamr not found.

What can I do with it?
Please help:-)